aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/final/Makefile')
-rw-r--r--toolchain/gcc/final/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index b815f677d6..0315b9d1f1 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -4,7 +4,6 @@ include ../common.mk
GCC_CONFIGURE += \
--with-headers=$(TOOLCHAIN_DIR)/include \
- --disable-libsanitizer \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
@@ -12,6 +11,10 @@ GCC_CONFIGURE += \
--enable-lto \
--with-libelf=$(TOPDIR)/staging_dir/host
+ifndef CONFIG_USE_GLIBC
+ GCC_CONFIGURE += --disable-libsanitizer
+endif
+
ifdef CONFIG_USE_MUSL
GCC_MAKE += gcc_cv_libc_provides_ssp=yes
endif