aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 25f7e1ef70..ebe4b484cf 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -37,6 +37,10 @@ ifeq ($(PKG_VERSION),12.2.0)
PKG_HASH:=e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
endif
+ifeq ($(PKG_VERSION),13.1.0)
+ PKG_HASH:=61d684f0aa5e76ac6585ad8898a2427aade8979ed5e7f85492286c4dfc13ee86
+endif
+
PATCH_DIR=../patches-$(GCC_MAJOR_VERSION).x
BUGURL=http://bugs.openwrt.org/
@@ -187,10 +191,10 @@ define Host/SetToolchainInfo
endef
-ifeq ($(GCC_MAJOR_VERSION),12)
- GCC_VERSION_FILE:=gcc/genversion.cc
-else
+ifeq ($(GCC_MAJOR_VERSION),11)
GCC_VERSION_FILE:=gcc/version.c
+else
+ GCC_VERSION_FILE:=gcc/genversion.cc
endif
ifneq ($(GCC_PREPARE),)