aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts163
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata4
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk20
4 files changed, 191 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts b/target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts
new file mode 100644
index 0000000000..f9e3f0a696
--- /dev/null
+++ b/target/linux/ath79/dts/qca9563_tplink_eap245-v3.dts
@@ -0,0 +1,163 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+ compatible = "tplink,eap245-v3", "qca,qca9563";
+ model = "TP-Link EAP245 v3";
+
+ aliases {
+ led-boot = &led_status_green;
+ led-failsafe = &led_status_amber;
+ led-running = &led_status_green;
+ led-upgrade = &led_status_amber;
+ label-mac-device = &eth0;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_status_green: status_green {
+ label = "tp-link:green:status";
+ gpios = <&gpio 7 GPIO_ACTIVE_HIGH>;
+ default-state = "on";
+ };
+
+ led_status_amber: status_amber {
+ label = "tp-link:amber:status";
+ gpios = <&gpio 9 GPIO_ACTIVE_HIGH>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "Reset button";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "factory-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot";
+ reg = <0x040000 0x040000>;
+ read-only;
+ };
+
+ partition@80000 {
+ label = "partition-table";
+ reg = <0x080000 0x010000>;
+ read-only;
+ };
+
+ info: partition@90000 {
+ label = "info";
+ reg = <0x090000 0x010000>;
+ read-only;
+ };
+
+ art: partition@a0000 {
+ label = "art";
+ reg = <0x0a0000 0x010000>;
+ read-only;
+ };
+
+ partition@b0000 {
+ label = "extra-para";
+ reg = <0x0b0000 0x010000>;
+ read-only;
+ };
+
+ partition@c0000 {
+ compatible = "openwrt,elf";
+ label = "firmware";
+ reg = <0x0c0000 0xe40000>;
+ };
+
+ partition@f00000 {
+ label = "config";
+ reg = <0xf00000 0x030000>;
+ read-only;
+ };
+
+ partition@f30000 {
+ label = "mutil-log";
+ reg = <0xf30000 0x080000>;
+ read-only;
+ };
+
+ partition@fb0000 {
+ label = "oops";
+ reg = <0xfb0000 0x040000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy-mask = <0x1>;
+
+ phy0: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "sgmii";
+ qca,ar8327-initvals = <
+ 0x04 0x00080080 /* PAD0 */
+ 0x7c 0x0000007e /* PORT0_STATUS */
+ 0xe0 0xc74164de /* SGMII_CTRL */
+ >;
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-handle = <&phy0>;
+ phy-mode = "sgmii";
+
+ mtd-mac-address = <&info 0x8>;
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&info 0x8>;
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 34dd975e19..2923ffabeb 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -301,6 +301,10 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "3:lan:3" "4:lan:2" "5:lan:1" "6@eth0" "2:wan:4" "1:wan:5"
;;
+ tplink,eap245-v3)
+ ucidef_add_switch "switch0" \
+ "0@eth0" "2:lan:1" "5:lan:2"
+ ;;
tplink,tl-mr6400-v1)
ucidef_set_interfaces_lan_wan "eth0.1 eth1" "usb0"
ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 66777cb9f5..1bfb8c2c61 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -206,6 +206,10 @@ case "$FIRMWARE" in
ln -sf /lib/firmware/ath10k/pre-cal-pci-0000\:00\:00.0.bin \
/lib/firmware/ath10k/QCA9888/hw2.0/board.bin
;;
+ tplink,eap245-v3)
+ caldata_extract "art" 0x5000 0x2f20
+ ath10k_patch_mac $(macaddr_add $(mtd_get_mac_binary info 0x8) +1)
+ ;;
yuncore,a782|\
yuncore,xd4200)
caldata_extract "art" 0x5000 0x2f20
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 7128d853f8..daf793671f 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -362,6 +362,26 @@ define Device/tplink_cpe610-v2
endef
TARGET_DEVICES += tplink_cpe610-v2
+define Device/tplink-eap2x5
+ $(Device/tplink-safeloader)
+ SOC := qca9563
+ LOADER_TYPE := elf
+ KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
+ KERNEL_INITRAMFS := $$(KERNEL)
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory | \
+ pad-extra 128
+endef
+
+define Device/tplink_eap245-v3
+ $(Device/tplink-eap2x5)
+ IMAGE_SIZE := 14592k
+ DEVICE_MODEL := EAP245
+ DEVICE_VARIANT := v3
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca99x0-ct
+ TPLINK_BOARD_ID := EAP245-V3
+endef
+TARGET_DEVICES += tplink_eap245-v3
+
define Device/tplink_re350k-v1
$(Device/tplink-safeloader)
SOC := qca9558