aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh11
-rw-r--r--target/linux/ramips/dts/RBM33G.dts156
-rw-r--r--target/linux/ramips/image/mt7621.mk14
-rw-r--r--target/linux/ramips/mt7621/config-4.141
-rw-r--r--target/linux/ramips/mt7621/target.mk2
7 files changed, 187 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index de086cf248..6d9b28f2c5 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -199,6 +199,7 @@ ramips_setup_interfaces()
jhr-n805r|\
jhr-n825r|\
jhr-n926r|\
+ mikrotik,rbm33g|\
mzk-wdpr|\
rb750gr3|\
rt-n14u|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index eb06442979..561e198040 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -207,6 +207,9 @@ get_status_led() {
m4-8M)
status_led="m4:blue:status"
;;
+ mikrotik,rbm33g)
+ status_led="rbm33g:green:usr"
+ ;;
miwifi-mini|\
zte-q7)
status_led="$boardname:red:status"
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index c094e41935..c2617b1a74 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -295,6 +295,7 @@ platform_check_image() {
nand_do_platform_check "$board" "$1"
return $?;
;;
+ mikrotik,rbm33g|\
re350-v1)
[ "$magic" != "01000000" ] && {
echo "Invalid image type."
@@ -316,6 +317,16 @@ platform_check_image() {
return 1
}
+platform_pre_upgrade() {
+ local board=$(board_name)
+
+ case "$board" in
+ mikrotik,rbm33g)
+ [ -z "$(rootfs_type)" ] && mtd erase firmware
+ ;;
+ esac
+}
+
platform_nand_pre_upgrade() {
local board=$(board_name)
diff --git a/target/linux/ramips/dts/RBM33G.dts b/target/linux/ramips/dts/RBM33G.dts
new file mode 100644
index 0000000000..ed2cb841dd
--- /dev/null
+++ b/target/linux/ramips/dts/RBM33G.dts
@@ -0,0 +1,156 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+ compatible = "mikrotik,rbm33g", "mediatek,mt7621-soc";
+ model = "MikroTik RBM33G";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x10000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ usr {
+ label = "rbm33g:green:usr";
+ gpios = <&gpio0 0 GPIO_ACTIVE_HIGH>;
+ };
+
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ res {
+ label = "res";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ pcie0_vcc_reg {
+ compatible = "regulator-fixed";
+ regulator-name = "pcie0_vcc";
+
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ gpio = <&gpio0 9 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ regulator-boot-on;
+ regulator-always-on;
+ };
+
+ pcie1_vcc_reg {
+ compatible = "regulator-fixed";
+ regulator-name = "pcie1_vcc";
+
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ gpio = <&gpio0 10 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ regulator-boot-on;
+ regulator-always-on;
+ };
+
+ pcie2_vcc_reg {
+ compatible = "regulator-fixed";
+ regulator-name = "pcie2_vcc";
+
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ gpio = <&gpio0 11 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ regulator-boot-on;
+ regulator-always-on;
+ };
+
+ usb_vcc_reg {
+ compatible = "regulator-fixed";
+ regulator-name = "usb_vcc";
+
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ gpio = <&gpio0 12 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ regulator-always-on;
+ };
+};
+
+
+&spi0 {
+ status = "okay";
+
+ w25q40@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <3125000>;
+
+ partition@0 {
+ label = "routerboot";
+ reg = <0x0 0xf000>;
+ read-only;
+ };
+
+ factory: partition@f000 {
+ label = "factory";
+ reg = <0xf000 0x71000>;
+ read-only;
+ };
+
+ };
+
+ w25q128@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <1>;
+ spi-max-frequency = <3125000>;
+
+ partition@40000 {
+ label = "firmware";
+ reg = <0x040000 0xFC0000>;
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x0010>;
+ mtd-mac-address-increment = <1>;
+};
+
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "uart2", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&sdhci {
+ status = "okay";
+};
+
+&i2c {
+ status = "okay";
+};
+
+&pcie {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f6f8ea065b..e9e2d3ecef 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -233,6 +233,20 @@ define Device/rb750gr3
endef
TARGET_DEVICES += rb750gr3
+define Device/mikrotik_rbm33g
+ DTS := RBM33G
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 16128k
+ DEVICE_TITLE := MikroTik RBM33G
+ DEVICE_PACKAGES := kmod-usb3
+ LOADER_TYPE := elf
+ PLATFORM := mt7621
+ KERNEL := kernel-bin | patch-dtb | lzma | loader-kernel
+ IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += mikrotik_rbm33g
+
define Device/re350-v1
DTS := RE350
DEVICE_TITLE := TP-LINK RE350 v1
diff --git a/target/linux/ramips/mt7621/config-4.14 b/target/linux/ramips/mt7621/config-4.14
index c19d735e5c..0e06023780 100644
--- a/target/linux/ramips/mt7621/config-4.14
+++ b/target/linux/ramips/mt7621/config-4.14
@@ -172,6 +172,7 @@ CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_SPI_NOR=y
CONFIG_MTD_SPLIT_FIRMWARE=y
+CONFIG_MTD_SPLIT_MINOR_FW=y
CONFIG_MTD_SPLIT_SEAMA_FW=y
CONFIG_MTD_SPLIT_TPLINK_FW=y
CONFIG_MTD_SPLIT_TRX_FW=y
diff --git a/target/linux/ramips/mt7621/target.mk b/target/linux/ramips/mt7621/target.mk
index 3c965abbe0..c2eba1d0da 100644
--- a/target/linux/ramips/mt7621/target.mk
+++ b/target/linux/ramips/mt7621/target.mk
@@ -4,7 +4,7 @@
SUBTARGET:=mt7621
BOARDNAME:=MT7621 based boards
-FEATURES+=nand ramdisk rtc usb
+FEATURES+=nand ramdisk rtc usb minor
CPU_TYPE:=24kc
define Target/Description