aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_dlink_dir-878-r1.dts37
-rw-r--r--target/linux/ramips/image/mt7621.mk11
2 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_dlink_dir-878-r1.dts b/target/linux/ramips/dts/mt7621_dlink_dir-878-r1.dts
new file mode 100644
index 0000000000..b6453bdd21
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_dlink_dir-878-r1.dts
@@ -0,0 +1,37 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_dlink_dir-8xx.dtsi"
+#include "mt7621_dlink_flash-16m-r1.dtsi"
+
+/ {
+ compatible = "dlink,dir-878-r1", "mediatek,mt7621-soc";
+ model = "D-Link DIR-878 R1";
+
+ aliases {
+ label-mac-device = &gmac0;
+ };
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_factory_e000>;
+ nvmem-cell-names = "mac-address";
+};
+
+&wan {
+ nvmem-cells = <&macaddr_factory_e006>;
+ nvmem-cell-names = "mac-address";
+};
+
+&factory {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_factory_e000: macaddr@e000 {
+ reg = <0xe000 0x6>;
+ };
+
+ macaddr_factory_e006: macaddr@e006 {
+ reg = <0xe006 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 8bef3a1bfb..cd28e36917 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -409,6 +409,17 @@ define Device/dlink_dir-878-a1
endef
TARGET_DEVICES += dlink_dir-878-a1
+define Device/dlink_dir-878-r1
+ $(Device/dlink_dir-8xx-r1)
+ DEVICE_MODEL := DIR-878
+ DEVICE_VARIANT := R1
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | check-size | \
+ sign-dlink-ru 57c5375741c30ca9ebcb36713db4ba51 \
+ ab0dff19af8842cdb70a86b4b68d23f7
+endef
+TARGET_DEVICES += dlink_dir-878-r1
+
define Device/dlink_dir-882-a1
$(Device/dlink_dir-8xx-a1)
DEVICE_MODEL := DIR-882