aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi29
-rw-r--r--target/linux/ramips/image/mt7621.mk2
2 files changed, 30 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi b/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
index 03fe467578..43f31cf2b6 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-gst.dtsi
@@ -194,7 +194,34 @@
&pcie {
status = "okay";
- /* WRC-xxxxGST has MT7615 for 2.4/5 GHz wifi, but it's not supported */
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+
+ led {
+ led-sources = <0>;
+ led-active-low;
+ };
+ };
};
&xhci {
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ff4dca91b8..848a0785fb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -291,6 +291,7 @@ define Device/elecom_wrc-1900gst
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
elecom-gst-factory WRC-1900GST 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
endef
TARGET_DEVICES += elecom_wrc-1900gst
@@ -302,6 +303,7 @@ define Device/elecom_wrc-2533gst
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
elecom-gst-factory WRC-2533GST 0.00
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
endef
TARGET_DEVICES += elecom_wrc-2533gst