aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds7
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/DWR-118-A2.dts179
-rw-r--r--target/linux/ramips/image/mt7620.mk14
-rw-r--r--target/linux/ramips/mt7620/config-4.141
7 files changed, 208 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 4e90efd4e6..44511bb0f6 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -162,6 +162,13 @@ dlink,dwr-116-a1|\
mzk-ex300np)
set_wifi_led "$boardname:green:wifi"
;;
+dlink,dwr-118-a2)
+ ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x0e"
+ ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
+ set_wifi_led "$boardname:green:wlan2g" "wlan1"
+ set_usb_led "$boardname:green:usb"
+ ucidef_set_led_default "internet" "internet" "$boardname:green:internet" "0"
+ ;;
dlink,dwr-921-c1)
set_wifi_led "$boardname:green:wifi"
ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x0f"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 915c3584c5..b6f70ef50d 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -157,6 +157,10 @@ ramips_setup_interfaces()
wrh-300cr)
ucidef_set_interface_lan "eth0"
;;
+ dlink,dwr-118-a2)
+ ucidef_add_switch "switch0" \
+ "1:lan:2" "2:lan:1" "3:lan:3" "4:lan" "0:wan" "6@eth0"
+ ;;
mir3g)
ucidef_add_switch "switch0" \
"2:lan:2" "3:lan:1" "1:wan" "6t@eth0"
@@ -462,6 +466,7 @@ ramips_setup_macs()
wan_mac=$(mtd_get_mac_ascii factory wanmac)
;;
dlink,dwr-116-a1|\
+ dlink,dwr-118-a2|\
dlink,dwr-921-c1)
wan_mac=$(jboot_config_read -m -i $(find_mtd_part "config") -o 0xE000)
lan_mac=$(macaddr_add "$wan_mac" 1)
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index c0c6a3ecad..711b8388ba 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -55,6 +55,7 @@ case "$FIRMWARE" in
"soc_wmac.eeprom")
case $board in
dlink,dwr-116-a1|\
+ dlink,dwr-118-a2|\
dlink,dwr-921-c1)
wan_mac=$(jboot_config_read -m -i $(find_mtd_part "config") -o 0xE000)
wifi_mac=$(macaddr_add "$wan_mac" 1)
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index a102a0bf7a..67c032cb8a 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -289,6 +289,7 @@ platform_check_image() {
return 0
;;
dlink,dwr-116-a1|\
+ dlink,dwr-118-a2|\
dlink,dwr-921-c1|\
dwr-512-b)
[ "$magic" != "0404242b" ] && {
diff --git a/target/linux/ramips/dts/DWR-118-A2.dts b/target/linux/ramips/dts/DWR-118-A2.dts
new file mode 100644
index 0000000000..f36ecb5b20
--- /dev/null
+++ b/target/linux/ramips/dts/DWR-118-A2.dts
@@ -0,0 +1,179 @@
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "dlink,dwr-118-a2", "ralink,mt7620a-soc";
+ model = "D-Link DWR-118 A2";
+
+ aliases {
+ led-status = &led_internet;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ wan {
+ label = "dwr-118-a2:green:wan";
+ gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+ };
+
+ led_internet: internet {
+ label = "dwr-118-a2:green:internet";
+ gpios = <&gpio2 0 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "dwr-118-a2:green:lan";
+ gpios = <&gpio2 1 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "dwr-118-a2:green:wlan2g";
+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "dwr-118-a2:green:usb";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+
+ };
+
+ gpio_export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ usb {
+ gpio-export,name = "usb";
+ gpio-export,output = <1>;
+ gpios = <&gpio1 14 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&gpio2 {
+ status = "okay";
+};
+
+&gpio3 {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "jboot";
+ reg = <0x0 0x10000>;
+ read-only;
+ };
+
+ partition@10000 {
+ label = "firmware";
+ reg = <0x10000 0xfe0000>;
+ };
+
+ config: partition@ff0000 {
+ label = "config";
+ reg = <0xff0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "ephy", "uartf", "spi refclk", "wled";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ mtd-mac-address = <&config 0xe4a8>;
+ mtd-mac-address-increment = <(2)>;
+
+ led {
+ led-sources = <2>;
+ led-active-low;
+ };
+ };
+};
+
+&ethernet {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&rgmii1_pins &mdio_pins>;
+
+ port@4 {
+ status = "okay";
+ phy-handle = <&phy4>;
+ phy-mode = "rgmii";
+ };
+
+ mdio-bus {
+ status = "okay";
+
+ phy4: ethernet-phy@4 {
+ reg = <4>;
+ phy-mode = "rgmii";
+ };
+ };
+};
+
+&gsw {
+ mediatek,port4 = "gmac";
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c759a89f24..c511a17ac1 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -164,6 +164,20 @@ define Device/dlink_dwr-116-a1
endef
TARGET_DEVICES += dlink_dwr-116-a1
+define Device/dlink_dwr-118-a2
+ DTS := DWR-118-A2
+ DEVICE_TITLE := D-Link DWR-118 A2
+ DEVICE_PACKAGES := kmod-usb2 jboot-tools kmod-mt76
+ DLINK_ROM_ID := DLK6E3814001
+ DLINK_FAMILY_MEMBER := 0x6E38
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+ IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
+endef
+TARGET_DEVICES += dlink_dwr-118-a2
+
define Device/dlink_dwr-921-c1
DTS := DWR-921-C1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
diff --git a/target/linux/ramips/mt7620/config-4.14 b/target/linux/ramips/mt7620/config-4.14
index 89de071446..1162ed47b2 100644
--- a/target/linux/ramips/mt7620/config-4.14
+++ b/target/linux/ramips/mt7620/config-4.14
@@ -128,6 +128,7 @@ CONFIG_IRQ_INTC=y
CONFIG_IRQ_MIPS_CPU=y
CONFIG_IRQ_WORK=y
CONFIG_LIBFDT=y
+CONFIG_MARVELL_PHY=y
CONFIG_MDIO_BUS=y
CONFIG_MDIO_DEVICE=y
CONFIG_MFD_SYSCON=y