aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/modules.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 656500b290..87733c2850 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -19,3 +19,18 @@ define KernelPackage/sound-cs5535audio/description
endef
$(eval $(call KernelPackage,sound-cs5535audio))
+
+define KernelPackage/sp5100_tco
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=SP5100 Watchdog Support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_SP5100_TCO
+ FILES:=$(LINUX_DIR)/drivers/watchdog/sp5100_tco.ko
+ AUTOLOAD:=$(call AutoLoad,50,sp5100_tco,1)
+endef
+
+define KernelPackage/sp5100_tco/description
+ Kernel module for the SP5100_TCO hardware watchdog.
+endef
+
+$(eval $(call KernelPackage,sp5100_tco))