aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/files/Makefile1
-rw-r--r--target/sdk/files/Makefile2
-rwxr-xr-xtarget/toolchain/files/wrapper.sh1
3 files changed, 4 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 5aeedb74da..5020373792 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -13,6 +13,7 @@ export TOPDIR LC_ALL LANG
export OPENWRT_VERBOSE=s
all: help
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)
diff --git a/target/sdk/files/Makefile b/target/sdk/files/Makefile
index dca8bbe20e..89c6a109ee 100644
--- a/target/sdk/files/Makefile
+++ b/target/sdk/files/Makefile
@@ -15,6 +15,8 @@ export TOPDIR LC_ALL LANG SDK
world:
DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
+
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
ifneq ($(OPENWRT_BUILD),1)
diff --git a/target/toolchain/files/wrapper.sh b/target/toolchain/files/wrapper.sh
index 4b3f8f911a..09a9cac928 100755
--- a/target/toolchain/files/wrapper.sh
+++ b/target/toolchain/files/wrapper.sh
@@ -43,6 +43,7 @@ TOOLCHAIN_BIN_DIR="$REALNAME_DIR/"
# Set the PATH so that our run-time location is first
# (get_feature is run from the path, so this has to be set)
+export ORIG_PATH=${ORIG_PATH:-$PATH}
export PATH="$TOOLCHAIN_BIN_DIR":$PATH
export GCC_HONOUR_COPTS