aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/image/Makefile10
-rw-r--r--target/linux/realtek/image/rtl838x.mk10
2 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 7d35581488..6c7be4aa90 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -90,16 +90,6 @@ define Device/Default
check-size | append-metadata
endef
-# "NGE" refers to the uImage magic
-define Device/netgear_nge
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
- KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
- SOC := rtl8380
- IMAGE_SIZE := 14848k
- UIMAGE_MAGIC := 0x4e474520
- DEVICE_VENDOR := NETGEAR
-endef
-
include $(SUBTARGET).mk
$(eval $(call BuildImage))
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index b221ed74a2..a4f02ba352 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -105,6 +105,16 @@ define Device/iodata_bsh-g24mb
endef
TARGET_DEVICES += iodata_bsh-g24mb
+# "NGE" refers to the uImage magic
+define Device/netgear_nge
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ SOC := rtl8380
+ IMAGE_SIZE := 14848k
+ UIMAGE_MAGIC := 0x4e474520
+ DEVICE_VENDOR := NETGEAR
+endef
+
define Device/netgear_gs108t-v3
$(Device/netgear_nge)
DEVICE_MODEL := GS108T