aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 76f14ca41b..0a1436ddfd 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -223,8 +223,9 @@ define Image/Build/Profile/BC2
$(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
endef
+mtdlayout_all0256n=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
define Image/Build/Profile/ALL0256N
- $(call Image/Build/Template/GENERIC_4M,$(1),all0256n,ALL0256N)
+ $(call BuildFirmware/Generic,$(1),all0256n,board=ALL0256N,mtdlayout_all0256n,851968,3014656)
endef
define Image/Build/Profile/NBG419N