aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds6
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata4
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c187
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
-rw-r--r--target/linux/ar71xx/nand/config-default1
13 files changed, 220 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 8db964fc6b..c6dcf36fed 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -428,6 +428,12 @@ omy-x1)
qihoo-c301)
ucidef_set_led_wlan "wlan2g" "WLAN2G" "qihoo:red:status" "phy1tpt"
;;
+re450)
+ ucidef_set_led_netdev "lan_data" "LAN Data" "$board:green:lan_data" "eth0" "tx rx"
+ ucidef_set_led_netdev "lan_link" "LAN Link" "$board:green:lan_link" "eth0" "link"
+ ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "$board:blue:wlan2g" "phy1tpt"
+ ucidef_set_led_wlan "wlan5g" "WLAN 5 GHz" "$board:blue:wlan5g" "phy0tpt"
+ ;;
smart-300)
ucidef_set_led_netdev "wan" "WAN" "nc-link:green:wan" "eth0"
ucidef_set_led_switch "lan1" "LAN1" "nc-link:green:lan1" "switch0" "0x04"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index d163f6035f..8acd214ced 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -91,6 +91,7 @@ ar71xx_setup_interfaces()
rb-912uag-5hpnd|\
rb-sxt2n|\
rb-sxt5n|\
+ re450|\
rocket-m-xw|\
tl-mr10u|\
tl-mr11u|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index ff605ae0c4..d060ccf6e2 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -295,6 +295,9 @@ get_status_led() {
rb-sxt5n)
status_led="rb:green:power"
;;
+ re450)
+ status_led="$board:blue:power"
+ ;;
routerstation|\
routerstation-pro)
status_led="ubnt:green:rf"
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index b458ca313d..a4f426e142 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -86,6 +86,10 @@ case "$FIRMWARE" in
ath10kcal_extract "caldata" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) +2)
;;
+ re450)
+ ath10kcal_extract "art" 20480 2116
+ ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) -2)
+ ;;
tl-wdr6500-v2)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -2)
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 104b1de05c..3241100198 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -770,6 +770,9 @@ ar71xx_board_detect() {
*"Qihoo 360 C301")
name="qihoo-c301"
;;
+ *"RE450")
+ name="re450"
+ ;;
*"RouterBOARD 411/A/AH")
name="rb-411"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index d4b1410467..570aa686e3 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -343,6 +343,7 @@ platform_check_image() {
omy-x1|\
onion-omega|\
oolite|\
+ re450|\
smart-300|\
som9331|\
tellstick-znet-lite|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 3dad21a886..4b2f736a86 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -145,6 +145,7 @@ CONFIG_ATH79_MACH_R6100=y
# CONFIG_ATH79_MACH_RB922 is not set
# CONFIG_ATH79_MACH_RB95X is not set
# CONFIG_ATH79_MACH_RBSXTLITE is not set
+CONFIG_ATH79_MACH_RE450=y
CONFIG_ATH79_MACH_RW2458N=y
CONFIG_ATH79_MACH_SMART_300=y
CONFIG_ATH79_MACH_SOM9331=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 5bfb1624ba..21d6b51897 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1103,6 +1103,16 @@ config ATH79_MACH_MZK_W300NH
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_RE450
+ bool "TP-LINK RE450 board support"
+ select SOC_QCA955X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_RW2458N
bool "Redwave RW2458N board support"
select SOC_AR724X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 3065701693..6384c0604c 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -149,6 +149,7 @@ obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
obj-$(CONFIG_ATH79_MACH_RB922) += mach-rb922.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
+obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
obj-$(CONFIG_ATH79_MACH_SMART_300) += mach-smart-300.o
obj-$(CONFIG_ATH79_MACH_SOM9331) += mach-som9331.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
new file mode 100644
index 0000000000..25de6e729f
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
@@ -0,0 +1,187 @@
+/*
+ * TP-LINK Archer RE450 board support
+ *
+ * Copyright (c) 2013 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (c) 2016 Tal Keren <kooolk@gmail.com>
+ *
+ * Based on the Qualcomm Atheros AP135/AP136 reference board support code
+ * Copyright (c) 2012 Qualcomm Atheros
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/gpio.h>
+#include <linux/platform_data/mdio-gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define RE450_GPIO_LED_SYSTEM 12
+#define RE450_GPIO_LED_WLAN2G 13
+#define RE450_GPIO_LED_WLAN5G 14
+#define RE450_GPIO_LED_LAN_DATA 17
+#define RE450_GPIO_LED_JUMPSTART 21
+#define RE450_GPIO_LED_JUMPSTART_RED 22
+#define RE450_GPIO_LED_LAN_LINK 23
+
+#define RE450_GPIO_BTN_RESET 18
+#define RE450_GPIO_BTN_LED 19
+#define RE450_GPIO_BTN_JUMPSTART 20
+
+#define RE450_GPIO_SMI_MDIO 1
+#define RE450_GPIO_SMI_MDC 3
+
+#define RE450_LAN_PHYADDR 4
+
+#define RE450_KEYS_POLL_INTERVAL 20 /* msecs */
+#define RE450_KEYS_DEBOUNCE_INTERVAL (3 * RE450_KEYS_POLL_INTERVAL)
+
+#define RE450_WMAC_CALDATA_OFFSET 0x1000
+
+static const char *tl_re450_part_probes[] = {
+ "cmdlinepart",
+ NULL,
+};
+
+static struct flash_platform_data tl_re450_flash_data = {
+ .part_probes = tl_re450_part_probes,
+};
+
+static struct gpio_led re450_leds_gpio[] __initdata = {
+ {
+ .name = "re450:blue:power",
+ .gpio = RE450_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+ {
+ .name = "re450:blue:wlan2g",
+ .gpio = RE450_GPIO_LED_WLAN2G,
+ .active_low = 1,
+ },
+ {
+ .name = "re450:blue:wlan5g",
+ .gpio = RE450_GPIO_LED_WLAN5G,
+ .active_low = 1,
+ },
+ {
+ .name = "re450:blue:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART,
+ },
+ {
+ .name = "re450:red:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART_RED,
+ },
+ {
+ .name = "re450:green:lan_data",
+ .gpio = RE450_GPIO_LED_LAN_DATA,
+ .active_low = 1,
+ },
+ {
+ .name = "re450:green:lan_link",
+ .gpio = RE450_GPIO_LED_LAN_LINK,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button re450_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = RE450_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = RE450_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "WPS button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = RE450_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = RE450_GPIO_BTN_JUMPSTART,
+ .active_low = 1,
+ },
+ {
+ .desc = "Control LED button",
+ .type = EV_KEY,
+ .code = BTN_0,
+ .debounce_interval = RE450_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = RE450_GPIO_BTN_LED,
+ .active_low = 1,
+ },
+};
+
+static struct mdio_gpio_platform_data re450_mdio = {
+ .mdc = RE450_GPIO_SMI_MDC,
+ .mdio = RE450_GPIO_SMI_MDIO,
+ .phy_mask = ~BIT(RE450_LAN_PHYADDR),
+};
+
+static struct platform_device re450_phy_device = {
+ .name = "mdio-gpio",
+ .id = 0,
+ .dev = {
+ .platform_data = &re450_mdio,
+ },
+};
+
+static void __init re450_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f610008);
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+ u8 tmpmac[ETH_ALEN];
+
+ ath79_register_m25p80(&tl_re450_flash_data);
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(re450_leds_gpio),
+ re450_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, RE450_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(re450_gpio_keys),
+ re450_gpio_keys);
+
+ ath79_init_mac(tmpmac, mac, -1);
+ ath79_register_wmac(art + RE450_WMAC_CALDATA_OFFSET, tmpmac);
+
+ ath79_register_pci();
+
+ /* MDIO Interface */
+ platform_device_register(&re450_phy_device);
+
+ ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+
+ /* GMAC0 is connected to the RGMII interface to an Atheros AR8035-A */
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_eth0_data.mii_bus_dev = &re450_phy_device.dev;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(RE450_LAN_PHYADDR);
+ ath79_eth0_pll_data.pll_1000 = 0xa6000000;
+ ath79_eth0_pll_data.pll_100 = 0xa0000101;
+ ath79_eth0_pll_data.pll_10 = 0x80001313;
+ ath79_register_eth(0);
+}
+
+MIPS_MACHINE(ATH79_MACH_RE450, "RE450", "TP-LINK RE450",
+ re450_setup)
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 6ead9117eb..d18a71cf38 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -166,6 +166,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_951U, /* Mikrotik RouterBOARD 951Ui-2HnD */
ATH79_MACH_RB_SXTLITE2ND, /* Mikrotik RouterBOARD SXT Lite 2nD */
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
+ ATH79_MACH_RE450, /* TP-LINK RE450 */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
ATH79_MACH_SMART_300, /* NC-LINK SMART-300 */
ATH79_MACH_SOM9331, /* OpenEmbed SOM9331 */
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index e980c2f38c..3e7cfd5f27 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -68,6 +68,7 @@ CONFIG_ATH79_MACH_RB91X=y
CONFIG_ATH79_MACH_RB922=y
CONFIG_ATH79_MACH_RB95X=y
CONFIG_ATH79_MACH_RBSXTLITE=y
+# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RW2458N is not set
# CONFIG_ATH79_MACH_SMART_300 is not set
# CONFIG_ATH79_MACH_TEW_632BRP is not set
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index a6871825b7..515266b0f8 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -35,6 +35,7 @@
# CONFIG_ATH79_MACH_OM2P is not set
# CONFIG_ATH79_MACH_PB42 is not set
# CONFIG_ATH79_MACH_PB44 is not set
+# CONFIG_ATH79_MACH_RE450 is not set
# CONFIG_ATH79_MACH_RW2458N is not set
# CONFIG_ATH79_MACH_TEW_632BRP is not set
# CONFIG_ATH79_MACH_TEW_673GRU is not set