aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/layerscape/image/Makefile10
-rw-r--r--target/linux/layerscape/modules.mk3
2 files changed, 10 insertions, 3 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 165ed0e98f..85a6b822eb 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -24,6 +24,10 @@ define Build/append-ls-mc
dd if=$(STAGING_DIR_IMAGE)/$(1)-mc.itb >> $@
endef
+define Build/append-ls-ppfe
+ dd if=$(STAGING_DIR_IMAGE)/pfe.itb >> $@
+endef
+
define Build/append-ls-dpl
dd if=$(STAGING_DIR_IMAGE)/$(1)-dpl.dtb >> $@
endef
@@ -89,10 +93,12 @@ TARGET_DEVICES += ls1046ardb
define Device/ls1012ardb
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb kmod-ppfe ppfe-ls1012ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
+ kmod-ppfe layerscape-ppfe
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 15M | \
+ append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-ppfe | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-ls-rootfs-ext4 $(1) 23M | check-size 67108865
diff --git a/target/linux/layerscape/modules.mk b/target/linux/layerscape/modules.mk
index 0b34f96b33..5fef373ff5 100644
--- a/target/linux/layerscape/modules.mk
+++ b/target/linux/layerscape/modules.mk
@@ -8,7 +8,8 @@
define KernelPackage/ppfe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Freescale PPFE Driver support
- KCONFIG:=CONFIG_FSL_PPFE
+ DEPENDS:=@TARGET_layerscape
+ KCONFIG:=CONFIG_FSL_PPFE CONFIG_FSL_PPFE_UTIL_DISABLED
FILES:=$(LINUX_DIR)/drivers/staging/fsl_ppfe/pfe.ko
AUTOLOAD:=$(call AutoLoad,35,ppfe)
endef