aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/omap/Makefile2
-rw-r--r--target/linux/omap/config-4.142
-rw-r--r--target/linux/omap/config-4.92
3 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/omap/Makefile b/target/linux/omap/Makefile
index 539aded43a..fc8e40dee2 100644
--- a/target/linux/omap/Makefile
+++ b/target/linux/omap/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=omap
BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand squashfs ubifs
CPU_TYPE:=cortex-a8
CPU_SUBTYPE:=vfpv3
diff --git a/target/linux/omap/config-4.14 b/target/linux/omap/config-4.14
index d5f8171565..7c60947e30 100644
--- a/target/linux/omap/config-4.14
+++ b/target/linux/omap/config-4.14
@@ -729,6 +729,8 @@ CONFIG_WATCHDOG_CORE=y
CONFIG_XFRM_ALGO=y
CONFIG_XFRM_MIGRATE=y
CONFIG_XPS=y
+CONFIG_XZ_DEC_ARM=y
+CONFIG_XZ_DEC_BCJ=y
CONFIG_ZBOOT_ROM_BSS=0x0
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZLIB_DEFLATE=y
diff --git a/target/linux/omap/config-4.9 b/target/linux/omap/config-4.9
index d6f0649093..4272c2f90f 100644
--- a/target/linux/omap/config-4.9
+++ b/target/linux/omap/config-4.9
@@ -724,6 +724,8 @@ CONFIG_WATCHDOG_CORE=y
CONFIG_XFRM_ALGO=y
CONFIG_XFRM_MIGRATE=y
CONFIG_XPS=y
+CONFIG_XZ_DEC_ARM=y
+CONFIG_XZ_DEC_BCJ=y
CONFIG_ZBOOT_ROM_BSS=0x0
CONFIG_ZBOOT_ROM_TEXT=0x0
CONFIG_ZLIB_DEFLATE=y