aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Config.in9
-rw-r--r--target/sdk/Makefile3
2 files changed, 10 insertions, 2 deletions
diff --git a/target/sdk/Config.in b/target/sdk/Config.in
index 0c8a61d247..1984e242e7 100644
--- a/target/sdk/Config.in
+++ b/target/sdk/Config.in
@@ -7,4 +7,11 @@ config SDK
with a precompiled toolchain. It can be used to develop and
test packages for OpenWrt before including them in the buildroot
-
+config SDK_LLVM_BPF
+ bool "Build the LLVM-BPF toolchain tarball"
+ depends on BPF_TOOLCHAIN_BUILD_LLVM
+ default BUILDBOT
+ help
+ This is a tarball of the precompiled LLVM toolchain suitable
+ for unpacking into the buildroot/SDK. It is used to build packages
+ that ship with eBPF kernel modules
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 0606621192..7d7f09b514 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -34,7 +34,8 @@ EXCLUDE_DIRS:= \
*.install.flags \
*.install \
*/doc \
- */share/locale
+ */share/locale \
+ */llvm-bpf*
SDK_DIRS = \
$(STAGING_SUBDIR_HOST) \