aboutsummaryrefslogtreecommitdiffstats
path: root/target/llvm-bpf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/llvm-bpf/Makefile')
-rw-r--r--target/llvm-bpf/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/llvm-bpf/Makefile b/target/llvm-bpf/Makefile
new file mode 100644
index 0000000000..c9ada017e6
--- /dev/null
+++ b/target/llvm-bpf/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2021 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+override MAKEFLAGS=
+
+LLVM_VERSION := $(shell cat $(STAGING_DIR_HOST)/llvm-bpf/.llvm-version)
+
+LLVM_BPF_PREFIX := llvm-bpf-$(LLVM_VERSION).$(HOST_OS)-$(HOST_ARCH)
+LLVM_TAR := $(BIN_DIR)/$(LLVM_BPF_PREFIX).tar.xz
+
+$(LLVM_TAR): $(HOST_STAMP_INSTALLED)
+ tar -C $(STAGING_DIR_HOST) \
+ -I '$(STAGING_DIR_HOST)/bin/xz -7e -T$(if $(filter 1,$(NPROC)),2,0)' \
+ -cf $@.tmp llvm-bpf $(LLVM_BPF_PREFIX)
+ mv $@.tmp $@
+
+download:
+prepare:
+compile: $(LLVM_TAR)
+install: compile
+
+clean:
+ rm -f $(LLVM_TAR)