aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh3
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/ath79/image/generic.mk6
5 files changed, 19 insertions, 2 deletions
diff --git a/target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts b/target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts
new file mode 100644
index 0000000000..1527a796bb
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_plasmacloud_pa300e.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9533_plasmacloud_pa300.dtsi"
+
+/ {
+ compatible = "plasmacloud,pa300e", "qca,qca9533";
+ model = "Plasma Cloud PA300E";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index f868d8dc94..ac1fc4406d 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -150,6 +150,7 @@ ath79_setup_interfaces()
comfast,cf-e314n-v2|\
compex,wpj531-16m|\
plasmacloud,pa300|\
+ plasmacloud,pa300e|\
tplink,cpe210-v1|\
tplink,cpe220-v2|\
tplink,cpe220-v3|\
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh b/target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh
index 68733ccf15..002f5f9668 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/dualboot_datachk.sh
@@ -45,7 +45,8 @@ platform_do_upgrade_dualboot_datachk() {
# boot anymore to Linux until it was reflashed with ap51-flash.
local next_boot_part="1"
case "$(board_name)" in
- plasmacloud,pa300)
+ plasmacloud,pa300|\
+ plasmacloud,pa300e)
primary_kernel_mtd=3
;;
*)
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 3ce273990f..98861685dc 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -50,7 +50,8 @@ platform_do_upgrade() {
jjplus,ja76pf2)
redboot_fis_do_upgrade "$1" linux
;;
- plasmacloud,pa300)
+ plasmacloud,pa300|\
+ plasmacloud,pa300e)
PART_NAME="inactive"
platform_do_upgrade_dualboot_datachk "$1"
;;
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 935dee75d7..037d572d97 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1597,6 +1597,12 @@ define Device/plasmacloud_pa300
endef
TARGET_DEVICES += plasmacloud_pa300
+define Device/plasmacloud_pa300e
+ $(Device/plasmacloud_pa300-common)
+ DEVICE_MODEL := PA300E
+endef
+TARGET_DEVICES += plasmacloud_pa300e
+
define Device/qihoo_c301
$(Device/seama)
SOC := ar9344