aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 38c623bf27..768ec57044 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -27,14 +27,17 @@ define Build/loader-common
endef
define Build/loader-kernel
- $(call Build/loader-common,LOADER_DATA="$@")
+ $(call Build/loader-common, \
+ LOADER_DATA="$@" \
+ BOARD="$(DEVICE_NAME)" )
endef
define Build/loader-okli-compile
$(call Build/loader-common, \
FLASH_OFFS=$(LOADER_FLASH_OFFS) \
FLASH_MAX=$(LOADER_FLASH_MAX) \
- KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) )
+ KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) \
+ BOARD="$(DEVICE_NAME)" )
endef
# Arguments: <output name> <kernel offset>