aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts88
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_re305-v3.dts79
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_re305.dtsi86
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
-rw-r--r--target/linux/ramips/mt76x8/base-files/etc/board.d/02_network1
5 files changed, 183 insertions, 81 deletions
diff --git a/target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts b/target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts
index 6ac3730194..7948668b84 100644
--- a/target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts
+++ b/target/linux/ramips/dts/mt7628an_tplink_re305-v1.dts
@@ -1,68 +1,10 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-#include "mt7628an.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "mt7628an_tplink_re305.dtsi"
/ {
compatible = "tplink,re305-v1", "mediatek,mt7628an-soc";
model = "TP-Link RE305 v1";
-
- aliases {
- led-boot = &led_power;
- led-failsafe = &led_power;
- led-running = &led_power;
- led-upgrade = &led_power;
- label-mac-device = &ethernet;
- };
-
- keys {
- compatible = "gpio-keys";
-
- reset {
- label = "reset";
- gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_RESTART>;
- };
-
- wps {
- label = "wps";
- gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
- linux,code = <KEY_WPS_BUTTON>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- led_power: power {
- label = "blue:power";
- gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
- };
-
- wlan2g {
- label = "blue:wlan2g";
- gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy0tpt";
- };
-
- wlan5g {
- label = "blue:wlan5g";
- gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
- linux,default-trigger = "phy1tpt";
- };
-
- rssi1 {
- label = "red:rssi";
- gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
- };
-
- rssi2 {
- label = "blue:rssi";
- gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
- };
- };
};
&spi0 {
@@ -110,33 +52,17 @@
};
};
-&state_default {
- gpio {
- groups = "refclk", "wdt", "p0led_an", "p1led_an", "p2led_an", "p3led_an", "p4led_an";
- function = "gpio";
- };
-};
-
-&pcie {
- status = "okay";
-};
+&wlan5g {
+ mediatek,mtd-eeprom = <&radio 0x8000>;
-&pcie0 {
- mt76@0,0 {
- compatible = "mediatek,mt76";
- reg = <0x0000 0 0 0 0>;
- mediatek,mtd-eeprom = <&radio 0x8000>;
- ieee80211-freq-limit = <5000000 6000000>;
- nvmem-cells = <&macaddr_config_10008>;
- nvmem-cell-names = "mac-address";
- mac-address-increment = <2>;
- };
+ nvmem-cells = <&macaddr_config_10008>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <2>;
};
&wmac {
- status = "okay";
-
mediatek,mtd-eeprom = <&radio 0x0>;
+
nvmem-cells = <&macaddr_config_10008>;
nvmem-cell-names = "mac-address";
mac-address-increment = <1>;
diff --git a/target/linux/ramips/dts/mt7628an_tplink_re305-v3.dts b/target/linux/ramips/dts/mt7628an_tplink_re305-v3.dts
new file mode 100644
index 0000000000..652aebec83
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_re305-v3.dts
@@ -0,0 +1,79 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_tplink_re305.dtsi"
+
+/ {
+ compatible = "tplink,re305-v3", "mediatek,mt7628an-soc";
+ model = "TP-Link RE305 v3";
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x20000 0x7a0000>;
+ };
+
+ config: partition@7c0000 {
+ label = "config";
+ reg = <0x7c0000 0x30000>;
+ read-only;
+ };
+
+ radio: partition@7f0000 {
+ label = "radio";
+ reg = <0x7f0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&wlan5g {
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+
+ nvmem-cells = <&macaddr_config_2008>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <(-2)>;
+};
+
+&wmac {
+ mediatek,mtd-eeprom = <&radio 0x0>;
+
+ nvmem-cells = <&macaddr_config_2008>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <(-1)>;
+};
+
+&ethernet {
+ nvmem-cells = <&macaddr_config_2008>;
+ nvmem-cell-names = "mac-address";
+};
+
+&config {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_config_2008: macaddr@2008 {
+ reg = <0x2008 0x6>;
+ };
+};
diff --git a/target/linux/ramips/dts/mt7628an_tplink_re305.dtsi b/target/linux/ramips/dts/mt7628an_tplink_re305.dtsi
new file mode 100644
index 0000000000..029b955911
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_re305.dtsi
@@ -0,0 +1,86 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ label-mac-device = &ethernet;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "blue:power";
+ gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "blue:wlan2g";
+ gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wlan5g {
+ label = "blue:wlan5g";
+ gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ rssi1 {
+ label = "red:rssi";
+ gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+ };
+
+ rssi2 {
+ label = "blue:rssi";
+ gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "refclk", "wdt", "p0led_an", "p1led_an", "p2led_an", "p3led_an", "p4led_an";
+ function = "gpio";
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wlan5g: mt76@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&wmac {
+ status = "okay";
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 7862f7b799..5f5d281d5c 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -512,6 +512,16 @@ define Device/tplink_re305-v1
endef
TARGET_DEVICES += tplink_re305-v1
+define Device/tplink_re305-v3
+ $(Device/tplink-safeloader)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE305
+ DEVICE_VARIANT := v3
+ DEVICE_PACKAGES := kmod-mt76x2
+ TPLINK_BOARD_ID := RE305-V3
+endef
+TARGET_DEVICES += tplink_re305-v3
+
define Device/tplink_tl-mr3020-v3
$(Device/tplink-v2)
IMAGE_SIZE := 7808k
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index 7cdf27c004..638b8f2181 100644
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -25,6 +25,7 @@ ramips_setup_interfaces()
tplink,re200-v4|\
tplink,re220-v2|\
tplink,re305-v1|\
+ tplink,re305-v3|\
tplink,tl-mr3020-v3|\
tplink,tl-wr802n-v4|\
tplink,tl-wa801nd-v5|\