aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/image/nand.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 52631789d9..8d3d2ce5b2 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,13 +1,12 @@
# attention: only zlib compression is allowed for the boot fs
define Build/zyxel-buildkerneljffs
- rm -rf $(KDIR_TMP)/zyxelnbg6716
- mkdir -p $(KDIR_TMP)/zyxelnbg6716/image/boot
- cp $@ $(KDIR_TMP)/zyxelnbg6716/image/boot/vmlinux.lzma.uImage
+ mkdir -p $@.tmp/boot
+ cp $@ $@.tmp/boot/vmlinux.lzma.uImage
$(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
--big-endian --squash-uids -v -e 128KiB -q -f -n -x lzma -x rtime \
-o $@ \
- -d $(KDIR_TMP)/zyxelnbg6716/image
- rm -rf $(KDIR_TMP)/zyxelnbg6716
+ -d $@.tmp
+ rm -rf $@.tmp
endef
define Build/zyxel-factory