aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/AWM003-EVB.dts65
-rw-r--r--target/linux/ramips/image/rt305x.mk8
5 files changed, 1 insertions, 77 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 7de6377c74..37984a81af 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -153,7 +153,6 @@ ramips_setup_interfaces()
atp-52b|\
awm002-evb-4M|\
awm002-evb-8M|\
- awm003-evb|\
c20i|\
dir-645|\
f5d8235-v2|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index cb8031fd82..1dc1391800 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -76,9 +76,6 @@ ramips_board_detect() {
*"AWM002 EVB (8M)")
name="awm002-evb-8M"
;;
- *"AWM003 EVB")
- name="awm003-evb"
- ;;
*"BC2")
name="bc2"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 14f5ec2cb3..085bf94aac 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -27,7 +27,6 @@ platform_check_image() {
awapn2403|\
awm002-evb-4M|\
awm002-evb-8M|\
- awm003-evb|\
bc2|\
broadway|\
carambola|\
diff --git a/target/linux/ramips/dts/AWM003-EVB.dts b/target/linux/ramips/dts/AWM003-EVB.dts
deleted file mode 100644
index 7c23f34c26..0000000000
--- a/target/linux/ramips/dts/AWM003-EVB.dts
+++ /dev/null
@@ -1,65 +0,0 @@
-/dts-v1/;
-
-#include "AWM002-8M.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
- compatible = "AWM003", "ralink,rt5350-soc";
- model = "AsiaRF AWM003 EVB";
-
- memory@0 {
- device_type = "memory";
- reg = <0x0 0x4000000>;
- };
-
- gpio-leds {
- compatible = "gpio-leds";
-
- tx {
- label = "awm003-evb:green:tx";
- gpios = <&gpio0 15 1>;
- };
-
- rx {
- label = "awm003-evb:green:rx";
- gpios = <&gpio0 16 1>;
- };
-
- wps {
- label = "awm003-evb:green:wps";
- gpios = <&gpio0 21 1>;
- };
- };
-
- gpio-keys-polled {
- compatible = "gpio-keys-polled";
- #address-cells = <1>;
- #size-cells = <0>;
- poll-interval = <20>;
-
- reset_wps {
- label = "reset_wps";
- gpios = <&gpio0 0 1>;
- linux,code = <KEY_RESTART>;
- };
-
- mode {
- label = "mode";
- gpios = <&gpio0 20 1>;
- linux,code = <BTN_0>;
- };
- };
-};
-
-&m25p80 {
- compatible = "jedec,spi-nor";
-};
-
-&ethernet {
- mtd-mac-address = <&factory 0x28>;
-};
-
-&wmac {
- ralink,mtd-eeprom = <&factory 0>;
-};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 0735798a87..013f6c1178 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -144,18 +144,12 @@ TARGET_DEVICES += awm002-evb-4M
define Device/awm002-evb-8M
DTS := AWM002-EVB-8M
- DEVICE_TITLE := AsiaRF AWM002-EVB (8M)
+ DEVICE_TITLE := AsiaRF AWM002-EVB (8M)/AsiaRF AWM003 EVB
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-i2c-core kmod-i2c-gpio
endef
TARGET_DEVICES += awm002-evb-8M
-define Device/awm003-evb
- DTS := AWM003-EVB
- DEVICE_TITLE := AsiaRF AWM003 EVB
-endef
-TARGET_DEVICES += awm003-evb
-
define Device/awapn2403
DTS := AWAPN2403
BLOCKSIZE := 4k