aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/ramips/dts/BDCOM-WAP2100-SK.dts130
-rw-r--r--target/linux/ramips/image/mt7620.mk9
6 files changed, 149 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 825a65b1d1..29d3c31275 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -367,6 +367,10 @@ vocore-16M)
w502u)
set_wifi_led "rt2800pci-phy0::radio"
;;
+wap2100-sk)
+ set_usb_led "$boardname:green:usb"
+ set_wifi_led "$boardname:green:wlan2g"
+ ;;
we1026-5g-16m)
ucidef_set_led_netdev "lan" "LAN" "we1026-5g:green:lan" "eth0"
set_wifi_led "we1026-5g:green:wifi"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 9b189b3b9e..6d5db45c50 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -223,6 +223,7 @@ ramips_setup_interfaces()
ubnt-erx|\
ubnt-erx-sfp|\
ur-326n4g|\
+ wap2100-sk|\
wrtnode|\
wrtnode2p | \
wrtnode2r | \
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 249533f06e..28d5073525 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -556,6 +556,9 @@ ramips_board_detect() {
*"W502U")
name="w502u"
;;
+ *"WAP2100-SK")
+ name="wap2100-sk"
+ ;;
*"WCR-1166DS")
name="wcr-1166ds"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 7fb17743cd..f54f2fbe77 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -186,6 +186,8 @@ platform_check_image() {
widora,neo-32m|\
mqmaker,witi-256m|\
mqmaker,witi-512m|\
+ wap2100-sk|\
+ we1026-5g-16m|\
wizfi630a|\
wl-330n|\
wl-330n3g|\
@@ -217,7 +219,6 @@ platform_check_image() {
y1|\
y1s|\
youhua,wr1200js|\
- we1026-5g-16m|\
zbt-ape522ii|\
zbt-cpe102|\
zbt-wa05|\
diff --git a/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts b/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
new file mode 100644
index 0000000000..7f9cbe74bd
--- /dev/null
+++ b/target/linux/ramips/dts/BDCOM-WAP2100-SK.dts
@@ -0,0 +1,130 @@
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "bdcom,bdcom-wap2100-sk", "ralink,mt7620a-soc";
+ model = "BDCOM WAP2100-SK";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ usb {
+ label = "wap2100-sk:green:usb";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "wap2100-sk:green:wps";
+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "wap2100-sk:green:wlan2g";
+ gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ en25q128@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ firmware: partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xf70000>;
+ };
+ };
+};
+
+&gpio0 {
+ status = "okay";
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&gpio3 {
+ status = "okay";
+};
+
+&sdhci {
+ status = "okay";
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+ mediatek,portmap = "llllw";
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "wdt", "mdio", "spi refclk", "uartf", "wled";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b5d73f60c7..61a6e56937 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -80,6 +80,15 @@ define Device/ArcherMR200
endef
TARGET_DEVICES += ArcherMR200
+define Device/BDCOM-WAP2100-SK
+ DTS := BDCOM-WAP2100-SK
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ SUPPORTED_DEVICES += wap2100-sk
+ DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += BDCOM-WAP2100-SK
+
define Device/bocco
DTS := BOCCO
DEVICE_TITLE := YUKAI Engineering BOCCO