aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/layerscape/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 26c57678f1..88bf8d7b40 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -114,6 +114,21 @@ define Device/ls1012ardb
endef
TARGET_DEVICES += ls1012ardb
+define Device/ls1012afrdm
+ DEVICE_TITLE := ls1012afrdm-$(SUBTARGET)
+ DEVICE_PACKAGES += rcw-layerscape-ls1012afrdm uboot-layerscape-$(SUBTARGET)-ls1012afrdm \
+ kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012afrdm
+ DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 10M | \
+ append-ls-ppfe | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-ls-rootfs-ext4 $(1) 30M | check-size 67108865
+endef
+TARGET_DEVICES += ls1012afrdm
+
ifeq ($(SUBTARGET),armv8_64b)
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)