aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/alix2/target.mk2
-rw-r--r--target/linux/x86/generic/target.mk2
-rw-r--r--target/linux/x86/patches-3.10/150-pit-tick-rate.patch4
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/alix2/target.mk b/target/linux/x86/alix2/target.mk
index 36243a2e82..df046fb3e6 100644
--- a/target/linux/x86/alix2/target.mk
+++ b/target/linux/x86/alix2/target.mk
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev \
kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.15
+LINUX_VERSION:=3.10.17
CS5535_MASK:=0x0b000042
CPU_TYPE := geode
diff --git a/target/linux/x86/generic/target.mk b/target/linux/x86/generic/target.mk
index 41b8700a51..d95c0dc150 100644
--- a/target/linux/x86/generic/target.mk
+++ b/target/linux/x86/generic/target.mk
@@ -1,6 +1,6 @@
BOARDNAME:=Generic
-LINUX_VERSION:=3.10.15
+LINUX_VERSION:=3.10.17
define Target/Description
Build firmware images for x86 based boards
diff --git a/target/linux/x86/patches-3.10/150-pit-tick-rate.patch b/target/linux/x86/patches-3.10/150-pit-tick-rate.patch
index e53dfcc97b..7bf9bbdc42 100644
--- a/target/linux/x86/patches-3.10/150-pit-tick-rate.patch
+++ b/target/linux/x86/patches-3.10/150-pit-tick-rate.patch
@@ -1,7 +1,7 @@
--- a/include/linux/timex.h
+++ b/include/linux/timex.h
-@@ -143,6 +143,10 @@ extern void hardpps(const struct timespe
- int read_current_timer(unsigned long *timer_val);
+@@ -144,6 +144,10 @@ int read_current_timer(unsigned long *ti
+ void ntp_notify_cmos_timer(void);
/* The clock frequency of the i8253/i8254 PIT */
+#ifdef CONFIG_X86_RDC321X