aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86')
-rw-r--r--target/linux/x86/Makefile1
-rw-r--r--target/linux/x86/patches-4.19/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86/patches-4.19/100-fix_cs5535_clockevt.patch12
-rw-r--r--target/linux/x86/patches-4.19/200-pcengines-apu2-reboot.patch19
-rw-r--r--target/linux/x86/patches-4.19/800-hwmon-w83627ehf-dont-claim-nct677x.patch30
5 files changed, 0 insertions, 84 deletions
diff --git a/target/linux/x86/Makefile b/target/linux/x86/Makefile
index 509ccb47a2..533c0e5248 100644
--- a/target/linux/x86/Makefile
+++ b/target/linux/x86/Makefile
@@ -14,7 +14,6 @@ SUBTARGETS:=generic legacy geode 64
MAINTAINER:=Felix Fietkau <nbd@nbd.name>
KERNEL_PATCHVER:=4.14
-KERNEL_TESTING_PATCHVER:=4.19
KERNELNAME:=bzImage
diff --git a/target/linux/x86/patches-4.19/011-tune_lzma_options.patch b/target/linux/x86/patches-4.19/011-tune_lzma_options.patch
deleted file mode 100644
index e680f9c484..0000000000
--- a/target/linux/x86/patches-4.19/011-tune_lzma_options.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -324,7 +324,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
-
- quiet_cmd_lzma = LZMA $@
- cmd_lzma = (cat $(filter-out FORCE,$^) | \
-- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
-+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
- (rm -f $@ ; false)
-
- quiet_cmd_lzo = LZO $@
---- a/arch/x86/include/asm/boot.h
-+++ b/arch/x86/include/asm/boot.h
-@@ -24,7 +24,7 @@
- # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
- #endif
-
--#ifdef CONFIG_KERNEL_BZIP2
-+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
- # define BOOT_HEAP_SIZE 0x400000
- #else /* !CONFIG_KERNEL_BZIP2 */
- # define BOOT_HEAP_SIZE 0x10000
diff --git a/target/linux/x86/patches-4.19/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-4.19/100-fix_cs5535_clockevt.patch
deleted file mode 100644
index c3a7fce9ce..0000000000
--- a/target/linux/x86/patches-4.19/100-fix_cs5535_clockevt.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/drivers/clocksource/cs5535-clockevt.c
-+++ b/drivers/clocksource/cs5535-clockevt.c
-@@ -130,7 +130,8 @@ static irqreturn_t mfgpt_tick(int irq, v
- cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
- MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);
-
-- cs5535_clockevent.event_handler(&cs5535_clockevent);
-+ if (cs5535_clockevent.event_handler)
-+ cs5535_clockevent.event_handler(&cs5535_clockevent);
- return IRQ_HANDLED;
- }
-
diff --git a/target/linux/x86/patches-4.19/200-pcengines-apu2-reboot.patch b/target/linux/x86/patches-4.19/200-pcengines-apu2-reboot.patch
deleted file mode 100644
index 1426140183..0000000000
--- a/target/linux/x86/patches-4.19/200-pcengines-apu2-reboot.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/arch/x86/kernel/reboot.c
-+++ b/arch/x86/kernel/reboot.c
-@@ -469,6 +469,16 @@ static const struct dmi_system_id reboot
- },
- },
-
-+ /* PC Engines */
-+ { /* Handle problems with rebooting on PC Engines apu2 */
-+ .callback = set_pci_reboot,
-+ .ident = "PC Engines apu2",
-+ .matches = {
-+ DMI_MATCH(DMI_BOARD_VENDOR, "PC Engines"),
-+ DMI_MATCH(DMI_BOARD_NAME, "apu2"),
-+ },
-+ },
-+
- /* Sony */
- { /* Handle problems with rebooting on Sony VGN-Z540N */
- .callback = set_bios_reboot,
diff --git a/target/linux/x86/patches-4.19/800-hwmon-w83627ehf-dont-claim-nct677x.patch b/target/linux/x86/patches-4.19/800-hwmon-w83627ehf-dont-claim-nct677x.patch
deleted file mode 100644
index ef2e1333e7..0000000000
--- a/target/linux/x86/patches-4.19/800-hwmon-w83627ehf-dont-claim-nct677x.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/hwmon/w83627ehf.c
-+++ b/drivers/hwmon/w83627ehf.c
-@@ -2717,8 +2717,8 @@ static int __init w83627ehf_find(int sio
- static const char sio_name_W83627UHG[] __initconst = "W83627UHG";
- static const char sio_name_W83667HG[] __initconst = "W83667HG";
- static const char sio_name_W83667HG_B[] __initconst = "W83667HG-B";
-- static const char sio_name_NCT6775[] __initconst = "NCT6775F";
-- static const char sio_name_NCT6776[] __initconst = "NCT6776F";
-+/* static const char sio_name_NCT6775[] __initconst = "NCT6775F";
-+ static const char sio_name_NCT6776[] __initconst = "NCT6776F"; */
-
- u16 val;
- const char *sio_name;
-@@ -2762,14 +2762,14 @@ static int __init w83627ehf_find(int sio
- sio_data->kind = w83667hg_b;
- sio_name = sio_name_W83667HG_B;
- break;
-- case SIO_NCT6775_ID:
-+/* case SIO_NCT6775_ID:
- sio_data->kind = nct6775;
- sio_name = sio_name_NCT6775;
- break;
- case SIO_NCT6776_ID:
- sio_data->kind = nct6776;
- sio_name = sio_name_NCT6776;
-- break;
-+ break; */
- default:
- if (val != 0xffff)
- pr_debug("unsupported chip ID: 0x%04x\n", val);