aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/profiles')
-rw-r--r--target/linux/x86/profiles/000-Generic.mk16
-rw-r--r--target/linux/x86/profiles/Soekris.mk16
-rw-r--r--target/linux/x86/profiles/s100.mk16
3 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/x86/profiles/000-Generic.mk b/target/linux/x86/profiles/000-Generic.mk
new file mode 100644
index 0000000000..d7e6b7eb1e
--- /dev/null
+++ b/target/linux/x86/profiles/000-Generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/profiles/Soekris.mk b/target/linux/x86/profiles/Soekris.mk
new file mode 100644
index 0000000000..8cce126039
--- /dev/null
+++ b/target/linux/x86/profiles/Soekris.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris
+ NAME:=Soekris Net4801
+ PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-scx200-gpio kmod-scx200-wdt kmod-hwmon-pc87360
+endef
+
+define Profile/Soekris/Description
+ Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
+endef
+$(eval $(call Profile,Soekris))
diff --git a/target/linux/x86/profiles/s100.mk b/target/linux/x86/profiles/s100.mk
new file mode 100644
index 0000000000..0a08a5c183
--- /dev/null
+++ b/target/linux/x86/profiles/s100.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/s100
+ NAME:=T-Vision S-100
+ FEATURES+=usb
+endef
+
+define Profile/s100/Description
+ T-Online streaming client.
+endef
+$(eval $(call Profile,s100))