aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/patches-5.4
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/patches-5.4')
-rw-r--r--target/linux/x86/patches-5.4/011-tune_lzma_options.patch22
-rw-r--r--target/linux/x86/patches-5.4/012-pcengines-apu2-detect-apuv4-board.patch50
-rw-r--r--target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch13
-rw-r--r--target/linux/x86/patches-5.4/300-pcengines_apu1_led.patch41
-rw-r--r--target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch30
5 files changed, 0 insertions, 156 deletions
diff --git a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch b/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
deleted file mode 100644
index 451c5bcb03..0000000000
--- a/target/linux/x86/patches-5.4/011-tune_lzma_options.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -328,7 +328,7 @@ quiet_cmd_bzip2 = BZIP2 $@
- # ---------------------------------------------------------------------------
-
- quiet_cmd_lzma = LZMA $@
-- cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@
-+ cmd_lzma = { cat $(real-prereqs) | $(LZMA) e -lc8 -eos -si -so; $(size_append); } > $@
-
- quiet_cmd_lzo = LZO $@
- cmd_lzo = { cat $(real-prereqs) | $(KLZOP) -9; $(size_append); } > $@
---- a/arch/x86/include/asm/boot.h
-+++ b/arch/x86/include/asm/boot.h
-@@ -24,7 +24,7 @@
- # error "Invalid value for CONFIG_PHYSICAL_ALIGN"
- #endif
-
--#ifdef CONFIG_KERNEL_BZIP2
-+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
- # define BOOT_HEAP_SIZE 0x400000
- #else /* !CONFIG_KERNEL_BZIP2 */
- # define BOOT_HEAP_SIZE 0x10000
diff --git a/target/linux/x86/patches-5.4/012-pcengines-apu2-detect-apuv4-board.patch b/target/linux/x86/patches-5.4/012-pcengines-apu2-detect-apuv4-board.patch
deleted file mode 100644
index f62617f992..0000000000
--- a/target/linux/x86/patches-5.4/012-pcengines-apu2-detect-apuv4-board.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 3d00da1de3ea36ba44f4a7ba76c8c8b16f98204b Mon Sep 17 00:00:00 2001
-From: "Enrico Weigelt, metux IT consult" <info@metux.net>
-Date: Thu, 12 Dec 2019 14:27:56 +0100
-Subject: [PATCH] platform/x86: pcengines-apuv2: detect apuv4 board
-
-GPIO stuff on APUv4 seems to be the same as on APUv2, so we just
-need to match on DMI data.
-
-Signed-off-by: Enrico Weigelt, metux IT consult <info@metux.net>
-Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
----
- drivers/platform/x86/pcengines-apuv2.c | 27 ++++++++++++++++++++++++++
- 1 file changed, 27 insertions(+)
-
---- a/drivers/platform/x86/pcengines-apuv2.c
-+++ b/drivers/platform/x86/pcengines-apuv2.c
-@@ -188,6 +188,33 @@ static const struct dmi_system_id apu_gp
- },
- .driver_data = (void *)&board_apu2,
- },
-+ /* APU4 w/ legacy bios < 4.0.8 */
-+ {
-+ .ident = "apu4",
-+ .matches = {
-+ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
-+ DMI_MATCH(DMI_BOARD_NAME, "APU4")
-+ },
-+ .driver_data = (void *)&board_apu2,
-+ },
-+ /* APU4 w/ legacy bios >= 4.0.8 */
-+ {
-+ .ident = "apu4",
-+ .matches = {
-+ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
-+ DMI_MATCH(DMI_BOARD_NAME, "apu4")
-+ },
-+ .driver_data = (void *)&board_apu2,
-+ },
-+ /* APU4 w/ mainline bios */
-+ {
-+ .ident = "apu4",
-+ .matches = {
-+ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
-+ DMI_MATCH(DMI_BOARD_NAME, "PC Engines apu4")
-+ },
-+ .driver_data = (void *)&board_apu2,
-+ },
- {}
- };
-
diff --git a/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch
deleted file mode 100644
index d4de2027ba..0000000000
--- a/target/linux/x86/patches-5.4/100-fix_cs5535_clockevt.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/drivers/clocksource/timer-cs5535.c
-+++ b/drivers/clocksource/timer-cs5535.c
-@@ -127,7 +127,9 @@ static irqreturn_t mfgpt_tick(int irq, v
- cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
- MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);
-
-- cs5535_clockevent.event_handler(&cs5535_clockevent);
-+ if (cs5535_clockevent.event_handler)
-+ cs5535_clockevent.event_handler(&cs5535_clockevent);
-+
- return IRQ_HANDLED;
- }
-
diff --git a/target/linux/x86/patches-5.4/300-pcengines_apu1_led.patch b/target/linux/x86/patches-5.4/300-pcengines_apu1_led.patch
deleted file mode 100644
index 9d1e4ab9c2..0000000000
--- a/target/linux/x86/patches-5.4/300-pcengines_apu1_led.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: Andreas Eberlein <foodeas@aeberlein.de>
-Subject: x86: add LED support for PC Engines APU1 with mainline bios
-
-This adds support for the LEDs on PC Engines APU1 with the mainline bios.
-
-Signed-off-by: Andreas Eberlein <foodeas@aeberlein.de>
----
---- a/drivers/leds/leds-apu.c
-+++ b/drivers/leds/leds-apu.c
-@@ -83,6 +83,7 @@ static const struct apu_led_profile apu1
- };
-
- static const struct dmi_system_id apu_led_dmi_table[] __initconst = {
-+ /* PC Engines APU with "Legacy" bios < 4.0.8 */
- {
- .ident = "apu",
- .matches = {
-@@ -90,6 +91,14 @@ static const struct dmi_system_id apu_le
- DMI_MATCH(DMI_PRODUCT_NAME, "APU")
- }
- },
-+ /* PC Engines APU with "Mainline" bios >= 4.0.8 */
-+ {
-+ .ident = "apu",
-+ .matches = {
-+ DMI_MATCH(DMI_SYS_VENDOR, "PC Engines"),
-+ DMI_MATCH(DMI_PRODUCT_NAME, "apu1")
-+ }
-+ },
- {}
- };
- MODULE_DEVICE_TABLE(dmi, apu_led_dmi_table);
-@@ -173,7 +182,7 @@ static int __init apu_led_init(void)
- int err;
-
- if (!(dmi_match(DMI_SYS_VENDOR, "PC Engines") &&
-- dmi_match(DMI_PRODUCT_NAME, "APU"))) {
-+ (dmi_match(DMI_PRODUCT_NAME, "APU") || dmi_match(DMI_PRODUCT_NAME, "apu1")))) {
- pr_err("No PC Engines APUv1 board detected. For APUv2,3 support, enable CONFIG_PCENGINES_APU2\n");
- return -ENODEV;
- }
diff --git a/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch b/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch
deleted file mode 100644
index a83ee3b6b8..0000000000
--- a/target/linux/x86/patches-5.4/800-hwmon-w83627ehf-dont-claim-nct677x.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/hwmon/w83627ehf.c
-+++ b/drivers/hwmon/w83627ehf.c
-@@ -2704,8 +2704,8 @@ static int __init w83627ehf_find(int sio
- static const char sio_name_W83627UHG[] __initconst = "W83627UHG";
- static const char sio_name_W83667HG[] __initconst = "W83667HG";
- static const char sio_name_W83667HG_B[] __initconst = "W83667HG-B";
-- static const char sio_name_NCT6775[] __initconst = "NCT6775F";
-- static const char sio_name_NCT6776[] __initconst = "NCT6776F";
-+/* static const char sio_name_NCT6775[] __initconst = "NCT6775F";
-+ static const char sio_name_NCT6776[] __initconst = "NCT6776F"; */
-
- u16 val;
- const char *sio_name;
-@@ -2749,14 +2749,14 @@ static int __init w83627ehf_find(int sio
- sio_data->kind = w83667hg_b;
- sio_name = sio_name_W83667HG_B;
- break;
-- case SIO_NCT6775_ID:
-+/* case SIO_NCT6775_ID:
- sio_data->kind = nct6775;
- sio_name = sio_name_NCT6775;
- break;
- case SIO_NCT6776_ID:
- sio_data->kind = nct6776;
- sio_name = sio_name_NCT6776;
-- break;
-+ break; */
- default:
- if (val != 0xffff)
- pr_debug("unsupported chip ID: 0x%04x\n", val);