aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index d31e4535df..0071ebda41 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -82,3 +82,23 @@ define KernelPackage/pcengines-apuv2/description
endef
$(eval $(call KernelPackage,pcengines-apuv2))
+
+
+define KernelPackage/meraki-mx100
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Cisco Meraki MX100 Platform Driver
+ DEPENDS:=@TARGET_x86 @!LINUX_5_4 +kmod-tg3 +kmod-gpio-button-hotplug +kmod-leds-gpio \
+ +kmod-usb-ledtrig-usbport +nu801 +kmod-itco-wdt
+ KCONFIG:=CONFIG_MERAKI_MX100
+ FILES:=$(LINUX_DIR)/drivers/platform/x86/meraki-mx100.ko
+ AUTOLOAD:=$(call AutoLoad,60,meraki-mx100,1)
+endef
+
+define KernelPackage/meraki-mx100/description
+ This driver provides support for the front button and LEDs on
+ the Cisco Meraki MX100 (Tinkerbell) 1U appliance. Note this also
+ selects the gpio-cdev nu801 userspace driver to support the Status
+ LED, as well as other required platform drivers.
+endef
+
+$(eval $(call KernelPackage,meraki-mx100))