aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/modules.mk')
-rw-r--r--target/linux/x86/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
new file mode 100644
index 0000000000..656500b290
--- /dev/null
+++ b/target/linux/x86/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+define KernelPackage/sound-cs5535audio
+ TITLE:=CS5535/CS5536 Audio Controller
+ DEPENDS:=@TARGET_x86_geode +kmod-ac97
+ KCONFIG:=CONFIG_SND_CS5535AUDIO
+ FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ Support for the integrated AC97 sound device on motherboards
+ with AMD CS5535/CS5536 chipsets.
+endef
+
+$(eval $(call KernelPackage,sound-cs5535audio))