aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/geode.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/image/geode.mk')
-rw-r--r--target/linux/x86/image/geode.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/x86/image/geode.mk b/target/linux/x86/image/geode.mk
new file mode 100644
index 0000000000..0b463e36ed
--- /dev/null
+++ b/target/linux/x86/image/geode.mk
@@ -0,0 +1,16 @@
+define Device/generic
+ DEVICE_TITLE := Generic x86/Geode
+ DEVICE_PACKAGES += kmod-crypto-cbc kmod-crypto-hw-geode kmod-ledtrig-gpio \
+ kmod-ledtrig-heartbeat kmod-ledtrig-netdev kmod-via-rhine
+ GRUB2_VARIANT := legacy
+endef
+TARGET_DEVICES += generic
+
+define Device/geos
+ $(call Device/generic)
+ DEVICE_TITLE := Traverse Technologies Geos
+ DEVICE_PACKAGES += br2684ctl flashrom kmod-8139cp kmod-hwmon-lm90 kmod-mppe \
+ kmod-pppoa kmod-usb-ohci-pci linux-atm ppp-mod-pppoa pppdump pppstats \
+ soloscli tc
+endef
+TARGET_DEVICES += geos