aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 12ffe18553..c070a10319 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -166,6 +166,13 @@ endif
define Image/BuildKernel
$(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
+ ifneq ($(CONFIG_X86_ETHERBOOT_IMAGES),)
+ rm -f $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+ $(STAGING_DIR_HOST)/bin/mkelfImage \
+ --append=$(CONFIG_X86_ETHERBOOT_BOOTOPTS) \
+ $(KDIR)/bzImage \
+ $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+ endif
endef
define Image/Prepare