aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/image/Makefile')
-rw-r--r--target/linux/x86/image/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 174c272a51..85c850c128 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -146,21 +146,7 @@ define Device/Default
ARTIFACTS := $$(ARTIFACTS-y)
endef
-ifeq ($(SUBTARGET),64)
- include 64.mk
-endif
-
-ifeq ($(SUBTARGET),generic)
- include generic.mk
-endif
-
-ifeq ($(SUBTARGET),geode)
- include geode.mk
-endif
-
-ifeq ($(SUBTARGET),legacy)
- include legacy.mk
-endif
+include $(SUBTARGET).mk
$(eval $(call BuildImage))