aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/geode
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/geode')
-rw-r--r--target/linux/x86/geode/profiles/000-Generic.mk20
-rw-r--r--target/linux/x86/geode/profiles/100-Geos.mk19
-rw-r--r--target/linux/x86/geode/target.mk5
3 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
new file mode 100644
index 0000000000..58dc3c641c
--- /dev/null
+++ b/target/linux/x86/geode/profiles/000-Generic.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:= \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90 \
+ kmod-via-rhine
+endef
+
+define Profile/Generic/Description
+ Generic Profile for all Geode boards.
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
new file mode 100644
index 0000000000..94e501edf4
--- /dev/null
+++ b/target/linux/x86/geode/profiles/100-Geos.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Geos
+ NAME:=Geos
+ PACKAGES:= \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90
+endef
+
+define Profile/Geos/Description
+ Traverse Technologies Geos ADSL router
+endef
+$(eval $(call Profile,Geos))
diff --git a/target/linux/x86/geode/target.mk b/target/linux/x86/geode/target.mk
index 4faa49f630..9c608e6f9d 100644
--- a/target/linux/x86/geode/target.mk
+++ b/target/linux/x86/geode/target.mk
@@ -6,6 +6,11 @@ DEFAULT_PACKAGES += \
kmod-button-hotplug \
kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
kmod-ledtrig-netdev hwclock wpad-mini
+# Geos
+DEFAULT_PACKAGES += \
+ soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+ hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+ kmod-usb-ohci-pci kmod-hwmon-lm90
define Target/Description
Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)