aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch')
-rw-r--r--target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
index 17c08cd6c5..200c684577 100644
--- a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
+++ b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.26/arch/um/Makefile-i386
-===================================================================
---- linux-2.6.26.orig/arch/um/Makefile-i386 2008-07-28 13:43:40.412036547 +0200
-+++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
@@ -35,7 +35,7 @@
# Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
# a lot more stack due to the lack of sharing of stacklots. Also, gcc
'#n170'>170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256
# Basic Keycodes

The basic set of keycodes are based on the [HID Keyboard/Keypad Usage Page (0x07)](https://www.usb.org/sites/default/files/documents/hut1_12v2.pdf) with the exception of `KC_NO`, `KC_TRNS` and keycodes in the `0xA5-DF` range. See below for more details.

## Letters and Numbers

|Key   |Description|
|------|-----------|
|`KC_A`|`a` and `A`|
|`KC_B`|`b` and `B`|
|`KC_C`|`c` and `C`|
|`KC_D`|`d` and `D`|
|`KC_E`|`e` and `E`|
|`KC_F`|`f` and `F`|
|`KC_G`|`g` and `G`|
|`KC_H`|`h` and `H`|
|`KC_I`|`i` and `I`|
|`KC_J`|`j` and `J`|
|`KC_K`|`k` and `K`|
|`KC_L`|`l` and `L`|
|`KC_M`|`m` and `M`|
|`KC_N`|`n` and `N`|
|`KC_O`|`o` and `O`|
|`KC_P`|`p` and `P`|
|`KC_Q`|`q` and `Q`|
|`KC_R`|`r` and `R`|
|`KC_S`|`s` and `S`|
|`KC_T`|`t` and `T`|
|`KC_U`|`u` and `U`|
|`KC_V`|`v` and `V`|
|`KC_W`|`w` and `W`|
|`KC_X`|`x` and `X`|
|`KC_Y`|`y` and `Y`|
|`KC_Z`|`z` and `Z`|
|`KC_1`|`1` and `!`|