aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi')
-rw-r--r--target/linux/sunxi/modules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99f4db7604..244c9ca508 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -20,6 +20,24 @@ endef
$(eval $(call KernelPackage,rtc-sunxi))
+define KernelPackage/rtc-sun6i
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Sun6i SoC built-in RTC support
+ DEPENDS:=@TARGET_sunxi
+ $(call AddDepends/rtc)
+ KCONFIG:= \
+ CONFIG_RTC_DRV_SUN6I \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sun6i.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-sun6i)
+endef
+
+define KernelPackage/rtc-sun6i/description
+ Support for the AllWinner sun6i SoC's onboard RTC
+endef
+
+$(eval $(call KernelPackage,rtc-sun6i))
+
define KernelPackage/sunxi-ir
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in IR support (A20)