aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sunxi/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sunxi/modules.mk')
-rw-r--r--target/linux/sunxi/modules.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99f4db7604..0c8ed83d0d 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -5,8 +5,7 @@
define KernelPackage/rtc-sunxi
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in RTC support
- DEPENDS:=@TARGET_sunxi
- $(call AddDepends/rtc)
+ DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT)
KCONFIG:= \
CONFIG_RTC_DRV_SUNXI \
CONFIG_RTC_CLASS=y
@@ -23,8 +22,7 @@ $(eval $(call KernelPackage,rtc-sunxi))
define KernelPackage/sunxi-ir
SUBMENU:=$(OTHER_MENU)
TITLE:=Sunxi SoC built-in IR support (A20)
- DEPENDS:=@TARGET_sunxi +kmod-input-core
- $(call AddDepends/rtc)
+ DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT) +kmod-input-core
KCONFIG:= \
CONFIG_MEDIA_SUPPORT=y \
CONFIG_MEDIA_RC_SUPPORT=y \