aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/sifiveu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/sifiveu/Makefile')
-rw-r--r--target/linux/sifiveu/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/sifiveu/Makefile b/target/linux/sifiveu/Makefile
new file mode 100644
index 0000000000..f88164e7af
--- /dev/null
+++ b/target/linux/sifiveu/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Copyright (C) 2022 Toco Technologies <info@toco.ae>
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=riscv64
+BOARD:=sifiveu
+BOARDNAME:=SiFive U-based RISC-V boards
+FEATURES:=ext4
+KERNELNAME:=Image dtbs
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=5.15
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for the SiFive U-based boards
+ (HiFive boards)
+endef
+
+$(eval $(call BuildTarget))