aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch')
-rw-r--r--target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch85
1 files changed, 0 insertions, 85 deletions
diff --git a/target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch b/target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch
deleted file mode 100644
index d01acaca46..0000000000
--- a/target/linux/s3c24xx/patches-2.6.31/052-touchscreen_filter.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From 2709e2e76025aa69d768a80d66ef1852dde7abc8 Mon Sep 17 00:00:00 2001
-From: Lars-Peter Clausen <lars@metafoo.de>
-Date: Tue, 21 Jul 2009 12:44:57 +0200
-Subject: [PATCH] 052-touchscreen_filter.patch
-
----
- drivers/input/touchscreen/Kconfig | 48 ++++++++++++++++++++++++++++++++++++
- drivers/input/touchscreen/Makefile | 5 +++
- 2 files changed, 53 insertions(+), 0 deletions(-)
-
-diff --git a/drivers/input/touchscreen/Kconfig b/drivers/input/touchscreen/Kconfig
-index 2bb711f..2b78885 100644
---- a/drivers/input/touchscreen/Kconfig
-+++ b/drivers/input/touchscreen/Kconfig
-@@ -11,6 +11,54 @@ menuconfig INPUT_TOUCHSCREEN
-
- if INPUT_TOUCHSCREEN
-
-+menuconfig TOUCHSCREEN_FILTER
-+ boolean "Touchscreen Filtering"
-+ depends on INPUT_TOUCHSCREEN
-+ select TOUCHSCREEN_FILTER_GROUP
-+ select TOUCHSCREEN_FILTER_MEDIAN
-+ select TOUCHSCREEN_FILTER_MEAN
-+ select TOUCHSCREEN_FILTER_LINEAR
-+ help
-+ Select this to include kernel touchscreen filter support. The filters
-+ can be combined in any order in your machine init and the parameters
-+ for them can also be set there.
-+
-+if TOUCHSCREEN_FILTER
-+
-+config TOUCHSCREEN_FILTER_GROUP
-+ bool "Group Touchscreen Filter"
-+ depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
-+ default Y
-+ help
-+ Say Y here if you want to use the Group touchscreen filter, it
-+ avoids using atypical samples.
-+
-+config TOUCHSCREEN_FILTER_MEDIAN
-+ bool "Median Average Touchscreen Filter"
-+ depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
-+ default Y
-+ help
-+ Say Y here if you want to use the Median touchscreen filter, it's
-+ highly effective if you data is noisy with occasional excursions.
-+
-+config TOUCHSCREEN_FILTER_MEAN
-+ bool "Mean Average Touchscreen Filter"
-+ depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
-+ default Y
-+ help
-+ Say Y here if you want to use the Mean touchscreen filter, it
-+ can further improve decent quality data by removing jitter
-+
-+config TOUCHSCREEN_FILTER_LINEAR
-+ bool "Linear Touchscreen Filter"
-+ depends on INPUT_TOUCHSCREEN && TOUCHSCREEN_FILTER
-+ default Y
-+ help
-+ Say Y here if you want to use the Linear touchscreen filter, it
-+ enables the use of calibration data for the touchscreen.
-+
-+endif
-+
- config TOUCHSCREEN_ADS7846
- tristate "ADS7846/TSC2046 and ADS7843 based touchscreens"
- depends on SPI_MASTER
-diff --git a/drivers/input/touchscreen/Makefile b/drivers/input/touchscreen/Makefile
-index 269814c..538e035 100644
---- a/drivers/input/touchscreen/Makefile
-+++ b/drivers/input/touchscreen/Makefile
-@@ -41,3 +41,8 @@ obj-$(CONFIG_TOUCHSCREEN_WM97XX_MAINSTONE) += mainstone-wm97xx.o
- obj-$(CONFIG_TOUCHSCREEN_WM97XX_ZYLONITE) += zylonite-wm97xx.o
- obj-$(CONFIG_TOUCHSCREEN_W90X900) += w90p910_ts.o
- obj-$(CONFIG_TOUCHSCREEN_S3C2410) += s3c2410_ts.o
-+obj-$(CONFIG_TOUCHSCREEN_FILTER) += ts_filter_chain.o
-+obj-$(CONFIG_TOUCHSCREEN_FILTER_GROUP) += ts_filter_group.o
-+obj-$(CONFIG_TOUCHSCREEN_FILTER_LINEAR) += ts_filter_linear.o
-+obj-$(CONFIG_TOUCHSCREEN_FILTER_MEDIAN) += ts_filter_median.o
-+obj-$(CONFIG_TOUCHSCREEN_FILTER_MEAN) += ts_filter_mean.o
---
-1.5.6.5
-