aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rtl838x/image/Makefile')
-rw-r--r--target/linux/rtl838x/image/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
new file mode 100644
index 0000000000..eef1fe0a33
--- /dev/null
+++ b/target/linux/rtl838x/image/Makefile
@@ -0,0 +1,44 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+KERNEL_LOADADDR = 0x80000000
+KERNEL_ENTRY = 0x80000400
+
+define Build/custom-uimage
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C gzip -a $(KERNEL_LOADADDR) $(if $(UIMAGE_MAGIC),-M $(UIMAGE_MAGIC),) \
+ -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n '$(1)' -d $@ $@.new
+ mv $@.new $@
+endef
+
+
+define Device/Default
+ PROFILES = Default
+ KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $$(SOC)_$(1)
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
+ append-metadata | check-size
+endef
+
+define Device/allnet_all-sg8208m
+ SOC := rtl8382
+ IMAGE_SIZE := 7168k
+ DEVICE_VENDOR := ALLNET
+ DEVICE_MODEL := ALL-SG8208M
+ UIMAGE_MAGIC := 0x00000006
+ KERNEL := kernel-bin | append-dtb | gzip | custom-uimage 2.2.2.0
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | custom-uimage 2.2.2.0
+ DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
+endef
+TARGET_DEVICES += allnet_all-sg8208m
+
+$(eval $(call BuildImage))