aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rtl838x/Makefile')
-rw-r--r--target/linux/rtl838x/Makefile27
1 files changed, 0 insertions, 27 deletions
diff --git a/target/linux/rtl838x/Makefile b/target/linux/rtl838x/Makefile
deleted file mode 100644
index a4e203718d..0000000000
--- a/target/linux/rtl838x/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-ARCH:=mips
-CPU_TYPE:=4kec
-BOARD:=rtl838x
-BOARDNAME:=Realtek MIPS
-DEVICE_TYPE:=basic
-FEATURES:=ramdisk squashfs
-SUBTARGETS:=generic
-
-KERNEL_PATCHVER:=5.4
-
-define Target/Description
- Build firmware images for Realtek RTL838x based boards.
-endef
-
-include $(INCLUDE_DIR)/target.mk
-
-FEATURES := $(filter-out mips16,$(FEATURES))
-
-DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
- dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
-
-$(eval $(call BuildTarget))