aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rockchip')
-rw-r--r--target/linux/rockchip/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index 22854d9d02..3c17e963be 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -24,7 +24,7 @@ endef
define Build/boot-script
# Make an U-boot image and copy it to the boot partition
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d mmc.bootscript $@.boot/boot.scr
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $(if $(1),$(1),mmc).bootscript $@.boot/boot.scr
endef
define Build/pine64-img