aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/armv8.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rockchip/image/armv8.mk')
-rw-r--r--target/linux/rockchip/image/armv8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
index 601ddcbdd6..9a32a07b21 100644
--- a/target/linux/rockchip/image/armv8.mk
+++ b/target/linux/rockchip/image/armv8.mk
@@ -60,3 +60,12 @@ define Device/radxa_rock-pi-4a
IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
endef
TARGET_DEVICES += radxa_rock-pi-4a
+
+define Device/xunlong_orangepi-r1-plus
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi R1 Plus
+ SOC := rk3328
+ IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+ DEVICE_PACKAGES := kmod-usb-net-rtl8152
+endef
+TARGET_DEVICES += xunlong_orangepi-r1-plus