aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rockchip/image/Makefile')
-rw-r--r--target/linux/rockchip/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index e4db1e5d58..e232166e51 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -16,7 +16,6 @@ define Build/boot-common
rm -fR $@.boot
mkdir -p $@.boot
- $(CP) $(DTS_DIR)/$(DEVICE_DTS).dtb $@.boot/rockchip.dtb
$(CP) $(IMAGE_KERNEL) $@.boot/kernel.img
endef
@@ -48,7 +47,7 @@ endef
### Devices ###
define Device/Default
PROFILES := Default
- KERNEL := kernel-bin
+ KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb
IMAGES := sysupgrade.img.gz
DEVICE_DTS = rockchip/$$(SOC)-$(lastword $(subst _, ,$(1)))
endef