aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rockchip/Makefile')
-rw-r--r--target/linux/rockchip/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/rockchip/Makefile b/target/linux/rockchip/Makefile
new file mode 100644
index 0000000000..41f0560bac
--- /dev/null
+++ b/target/linux/rockchip/Makefile
@@ -0,0 +1,24 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=rockchip
+BOARDNAME:=Rockchip
+FEATURES:=ext4 audio usb usbgadget display gpio fpu rootfs-part boot-part squashfs
+SUBTARGETS:=armv8
+
+KERNEL_PATCHVER=5.4
+
+define Target/Description
+ Build firmware image for Rockchip SoC devices.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs
+
+KERNELNAME:=Image dtbs
+
+$(eval $(call BuildTarget))