aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch')
-rw-r--r--target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch18
1 files changed, 3 insertions, 15 deletions
diff --git a/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch b/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
index 5aa988dc55..fae478a624 100644
--- a/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
+++ b/target/linux/realtek/patches-5.10/100-watchdog-add-realtek-otto-watchdog-timer.patch
@@ -30,11 +30,9 @@ Signed-off-by: Sander Vanheule <sander@svanheule.net>
4 files changed, 382 insertions(+)
create mode 100644 drivers/watchdog/realtek_otto_wdt.c
-diff --git a/MAINTAINERS b/MAINTAINERS
-index 2c9070aeba2a..54c8f788d3e5 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -15991,6 +15991,13 @@ S: Maintained
+@@ -14815,6 +14815,13 @@ S: Maintained
F: include/sound/rt*.h
F: sound/soc/codecs/rt*
@@ -48,11 +46,9 @@ index 2c9070aeba2a..54c8f788d3e5 100644
REALTEK RTL83xx SMI DSA ROUTER CHIPS
M: Linus Walleij <linus.walleij@linaro.org>
S: Maintained
-diff --git a/drivers/watchdog/Kconfig b/drivers/watchdog/Kconfig
-index bf59faeb3de1..d308e13a9aa1 100644
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -954,6 +954,19 @@ config RTD119X_WATCHDOG
+@@ -995,6 +995,19 @@ config RTD119X_WATCHDOG
Say Y here to include support for the watchdog timer in
Realtek RTD1295 SoCs.
@@ -72,11 +68,9 @@ index bf59faeb3de1..d308e13a9aa1 100644
config SPRD_WATCHDOG
tristate "Spreadtrum watchdog support"
depends on ARCH_SPRD || COMPILE_TEST
-diff --git a/drivers/watchdog/Makefile b/drivers/watchdog/Makefile
-index 1bd2d6f37c53..a8dccf819163 100644
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -171,6 +171,7 @@ obj-$(CONFIG_IMGPDC_WDT) += imgpdc_wdt.o
+@@ -174,6 +174,7 @@ obj-$(CONFIG_IMGPDC_WDT) += imgpdc_wdt.o
obj-$(CONFIG_MT7621_WDT) += mt7621_wdt.o
obj-$(CONFIG_PIC32_WDT) += pic32-wdt.o
obj-$(CONFIG_PIC32_DMT) += pic32-dmt.o
@@ -84,9 +78,6 @@ index 1bd2d6f37c53..a8dccf819163 100644
# PARISC Architecture
-diff --git a/drivers/watchdog/realtek_otto_wdt.c b/drivers/watchdog/realtek_otto_wdt.c
-new file mode 100644
-index 000000000000..48bc8dfefc25
--- /dev/null
+++ b/drivers/watchdog/realtek_otto_wdt.c
@@ -0,0 +1,361 @@
@@ -451,6 +442,3 @@ index 000000000000..48bc8dfefc25
+MODULE_LICENSE("GPL v2");
+MODULE_AUTHOR("Sander Vanheule <sander@svanheule.net>");
+MODULE_DESCRIPTION("Realtek Otto watchdog timer driver");
---
-2.31.1
-