aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/rtl838x.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/image/rtl838x.mk')
-rw-r--r--target/linux/realtek/image/rtl838x.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/realtek/image/rtl838x.mk b/target/linux/realtek/image/rtl838x.mk
index b2e0cc91be..192b88fe54 100644
--- a/target/linux/realtek/image/rtl838x.mk
+++ b/target/linux/realtek/image/rtl838x.mk
@@ -12,6 +12,22 @@ define Device/allnet_all-sg8208m
endef
TARGET_DEVICES += allnet_all-sg8208m
+define Device/apresia_aplgs120gtss
+ $(Device/cameo-fw)
+ SOC := rtl8382
+ IMAGE_SIZE := 14848k
+ DEVICE_VENDOR := APRESIA
+ DEVICE_MODEL := ApresiaLightGS120GT-SS
+ UIMAGE_MAGIC := 0x12345000
+ CAMEO_KERNEL_PART_SIZE := 1572864
+ CAMEO_KERNEL_PART := 3
+ CAMEO_ROOTFS_PART := 4
+ CAMEO_CUSTOMER_SIGNATURE := 2
+ CAMEO_BOARD_MODEL := APLGS120GTSS
+ CAMEO_BOARD_VERSION := 4
+endef
+TARGET_DEVICES += apresia_aplgs120gtss
+
define Device/d-link_dgs-1210-10mp-f
$(Device/d-link_dgs-1210)
SOC := rtl8380