aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/image/common.mk')
-rw-r--r--target/linux/realtek/image/common.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
index 59286b211d..560cf6c8e6 100644
--- a/target/linux/realtek/image/common.mk
+++ b/target/linux/realtek/image/common.mk
@@ -14,3 +14,14 @@ define Build/d-link_dgs-1210
append-rootfs | pad-rootfs | pad-to 16 | check-size | \
dlink-version | dlink-headers
endef
+
+define Build/hpe_1920
+ DEVICE_VENDOR := HPE
+ IMAGE_SIZE := 29632k
+ BLOCKSIZE := 64k
+ H3C_PRODUCT_ID := 0x3c010501
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image | h3c-vfs
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | relocate-kernel | 7z | h3c-image
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+ pad-rootfs | check-size | append-metadata
+endef