aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/image/common.mk')
-rw-r--r--target/linux/realtek/image/common.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/realtek/image/common.mk b/target/linux/realtek/image/common.mk
new file mode 100644
index 0000000000..59286b211d
--- /dev/null
+++ b/target/linux/realtek/image/common.mk
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+define Build/d-link_dgs-1210
+ IMAGE_SIZE := 13824k
+ DEVICE_VENDOR := D-Link
+ DLINK_KERNEL_PART_SIZE := 1572864
+ KERNEL := kernel-bin | append-dtb | gzip | uImage gzip | dlink-cameo
+ CAMEO_KERNEL_PART := 2
+ CAMEO_ROOTFS_PART := 3
+ CAMEO_CUSTOMER_SIGNATURE := 2
+ CAMEO_BOARD_VERSION := 32
+ IMAGES += factory_image1.bin
+ IMAGE/factory_image1.bin := append-kernel | pad-to 64k | \
+ append-rootfs | pad-rootfs | pad-to 16 | check-size | \
+ dlink-version | dlink-headers
+endef