aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/image/Makefile')
-rw-r--r--target/linux/realtek/image/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 026c6e0068..b54a1f0a8d 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -6,7 +6,8 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80000000
KERNEL_ENTRY = 0x80000400
-DEVICE_VARS += ZYXEL_VERS
+DEVICE_VARS += ZYXEL_VERS DLINK_KERNEL_PART_SIZE
+DEVICE_VARS += CAMEO_KERNEL_PART CAMEO_ROOTFS_PART CAMEO_CUSTOMER_SIGNATURE CAMEO_BOARD_VERSION
define Build/zyxel-vers
( echo VERS;\
@@ -16,6 +17,21 @@ define Build/zyxel-vers
done ) >> $@
endef
+define Build/dlink-headers
+ dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) count=1 of=$@.kernel_part; \
+ dd if=$@ bs=$(DLINK_KERNEL_PART_SIZE) skip=1 of=$@.rootfs_part; \
+ $(SCRIPT_DIR)/cameo-imghdr.py $@.kernel_part $@.kernel_part.hex \
+ "$(DEVICE_MODEL)" os $(CAMEO_KERNEL_PART) \
+ $(CAMEO_CUSTOMER_SIGNATURE) \
+ $(CAMEO_BOARD_VERSION) \
+ $(KERNEL_LOADADDR); \
+ $(SCRIPT_DIR)/cameo-imghdr.py $@.rootfs_part $@.rootfs_part.hex \
+ "$(DEVICE_MODEL)" squashfs $(CAMEO_ROOTFS_PART) \
+ $(CAMEO_CUSTOMER_SIGNATURE) \
+ $(CAMEO_BOARD_VERSION); \
+ cat $@.kernel_part.hex $@.rootfs_part.hex > $@
+endef
+
define Device/Default
PROFILES = Default
KERNEL := kernel-bin | append-dtb | gzip | uImage gzip