aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realtek/image/Makefile')
-rw-r--r--target/linux/realtek/image/Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
new file mode 100644
index 0000000000..4e9dbc350d
--- /dev/null
+++ b/target/linux/realtek/image/Makefile
@@ -0,0 +1,71 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+KERNEL_LOADADDR = 0x80000000
+KERNEL_ENTRY = 0x80000400
+
+define Device/Default
+ PROFILES = Default
+ KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS = $$(SOC)_$(1)
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+ IMAGES := sysupgrade.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
+ append-metadata | check-size
+endef
+
+define Device/allnet_all-sg8208m
+ SOC := rtl8382
+ IMAGE_SIZE := 7168k
+ DEVICE_VENDOR := ALLNET
+ DEVICE_MODEL := ALL-SG8208M
+ UIMAGE_MAGIC := 0x00000006
+ UIMAGE_NAME := 2.2.2.0
+ DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
+endef
+TARGET_DEVICES += allnet_all-sg8208m
+
+define Device/d-link_dgs-1210
+ SOC := rtl8382
+ IMAGE_SIZE := 13824k
+ DEVICE_VENDOR := D-Link
+ DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
+endef
+
+define Device/d-link_dgs-1210-10p
+ $(Device/d-link_dgs-1210)
+ DEVICE_MODEL := DGS-1210-10P
+ DEVICE_PACKAGES += lua-rs232
+endef
+TARGET_DEVICES += d-link_dgs-1210-10p
+
+define Device/d-link_dgs-1210-16
+ $(Device/d-link_dgs-1210)
+ DEVICE_MODEL := DGS-1210-16
+endef
+TARGET_DEVICES += d-link_dgs-1210-16
+
+define Device/d-link_dgs-1210-28
+ $(Device/d-link_dgs-1210)
+ DEVICE_MODEL := DGS-1210-28
+endef
+TARGET_DEVICES += d-link_dgs-1210-28
+
+define Device/netgear_gs110tpp-v1
+ $(Device/Default)
+ SOC := rtl8380
+ IMAGE_SIZE := 14848k
+ UIMAGE_MAGIC := 0x4e474520
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := GS110TP
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
+endef
+TARGET_DEVICES += netgear_gs110tpp-v1
+
+$(eval $(call BuildImage))